SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG
ANN ARBOR BEIGE BAG SOFTWARE OF ANN ARBOR SOFTWARE OF ANN ARBOR BEIGE BAG SOFTWARE OF
BEIGE BAG SOFTWARE OF ANN ARBOR BEIGE BAG

B²LOGIC™

A DIGITAL CIRCUIT DESIGN & SIMULATION PROGRAM FOR THE MAC & PC
Contents

Before You Start... ................................................................. 4
  About the Manual .............................................................. 4
  The B^2 Logic v. 2.2 Disk .................................................... 4
  System requirements .......................................................... 4
  Installation ........................................................................... 5
    Configuring Windows for Optimum Performance .................. 5
    How to use this manual .................................................... 6
    Technical Support ............................................................ 6

Tutorial #1 ........................................................................... 7
  Build a three input And function ......................................... 7

Tutorial #2 .......................................................................... 11
  Build a hierarchical circuit ............................................... 11
  Part I: Design of the 8-bit Adder ........................................ 11
  Part II: Building the 3-way adder ........................................ 16

Tutorial #3 ........................................................................... 18
  Adding Components to B^2 Logic ........................................ 18

Tools And Menus, and more .............................................. 21
  B^2 Logic Tools ................................................................. 21
  B^2 Logic Buttons and Fields .............................................. 22
  B^2 Logic Menus ................................................................ 22
    The File Menu ............................................................... 22
    The Edit Menu .............................................................. 23
    The Devices Menu ........................................................ 24
    The Zoom Menu ............................................................ 24
    The Simulation Menu ..................................................... 25
    The Windows Menu ....................................................... 25

Articles ................................................................................ 27
  Editing the Circuit ............................................................. 27
    Least Commitment Philosophy ........................................ 27
    Wire Intersection Strategy ............................................. 27
    Drawing wires ............................................................... 27
    Editing text fields .......................................................... 27
    Selecting objects ........................................................... 28
    Selecting wires .............................................................. 28
    Selecting more objects .................................................... 28
    Deleting Objects ........................................................... 28
    Editing Port Names and the Clock Period ......................... 28
    Moving objects ............................................................. 28
    Moving the whole circuit ................................................ 28
    Distribution of wires in buses .......................................... 29

Circuit Simulation ............................................................. 29
  Why the state is incorrect at times ...................................... 29
  Updating the circuit state .................................................. 29
  Changing input values ...................................................... 29
  Running the Simulation in Interactive Mode ....................... 29
  Running the Simulation from Command Files .................... 30
Before You Start...

About the Manual

This manual is for both the Macintosh and PC versions of B$^2$ Logic. The programs are nearly identical, in fact, circuits can be transferred between the two programs, but some minor cosmetic and functional differences exist. Special symbols are included to draw attention to features that are specific to the Macintosh version and to the Windows version. When the mouse button is mentioned, it means the left mouse button in the case of PC mice.

This manual discusses how to use B$^2$ Logic 2.2, and it includes functional descriptions for many devices available in the program.

The B$^2$ Logic v. 2.2 Disk

The B$^2$ Logic disk contains:

- B$^2$ Logic$^\text{TM}$ v. 2.2, a user-friendly, powerful circuit design and simulation program.

A folder/directory containing example circuits.

- The Macintosh version also includes The Device Encyclopedia$^\text{TM}$, which runs on top of Hypercard. This stack contains working models of many devices available from within the B$^2$ Logic 2.2 program, and instructions on how to use each device. The Device Encyclopedia$^\text{TM}$ is easy to learn to use. Just fire it up and click away.

System requirements

- B$^2$ Logic 2.2 for the Mac requires any Mac with at least 1 MB of RAM and System 4.2 or later.

  The Device Encyclopedia$^\text{TM}$ requires Hypercard and at least 1 MB of RAM.

- B$^2$ Logic 2.2 for Windows requires at least Windows 3.0, a 286 processor or later, a mouse, and at least 1 MB of memory.

Installation

- Installing the Macintosh version is as easy as moving the icon of the B$^2$ Logic disk onto the icon of the hard drive. The Macintosh finder will install all of the files from the disk onto your hard drive.

- Installation of PC version- see additional notes sheet for latest instructions. To install the version for Windows onto your hard drive, start up Microsoft Windows, and run the File Manager application. (We suggest that you run Windows 3.0 in Standard mode for maximum speed- for Windows 3.1, use enhanced mode if you can). Insert your program disk into drive A or B. Click on the icon of the disk drive that you inserted the disk into, and then double click on the icon of the top-level directory for the disk. The screen should now show a window with the batch files INSTALLA.BAT, and INSTALLB.BAT. Double click on the batch file that matches the current disk drive, and the program will be installed. To check the installation, switch to the B$^2$LOGIC directory on your C: drive, and look for the BSQUARED.EXE application. (If you know how to use DOS, simply run the install program that matches the disk drive that the disk is in.)

  To finish the job, quit the File Manager and return to the Program Manager, and choose New... from the File Menu. Choose Program Item on the next screen, and then enter B2 Logic for the Description, and c:\b2logic\bsquared.exe, the pathname of the application, for the Command Line. Use the Change Icon option to find the chip icon for the program. When you OK the dialog box, the icon should be available in the Main program group of the Program Manager Window. Double click on this icon to run the program.

  If you want to run the program from your floppy drive, use the same procedure outlined in the above paragraph, but enter a:\bsquared.exe for the Command Line.

Configuring Windows for Optimum Performance

- B$^2$ Logic can run in Windows' Standard and 386-enhanced modes. Use the following advice to determine which mode to use.

  If your machine has a 286 processor, or if your machine has less than 2MB of RAM, then you shouldn't have to do anything more. Windows should run in Standard mode by default, which is the mode you want to run in. If Windows is not running in standard mode, then you should type win/s at the DOS prompt to run Windows in standard mode.
If your machine has a 386 processor or higher, and you have 2 Megabytes of RAM or more, then you can run the program in either Standard or 386-enhanced mode. B² Logic will run faster in Standard mode than in 386-enhanced mode, however B² Logic will be able to use much more memory in 386-enhanced mode than it can in Standard mode.

If you have only one Megabyte of RAM, make sure that B² Logic is the only program running under Windows besides the Program Manager (which must be running for Windows to execute). In fact, if you are building very large circuits, then B² Logic should be the only program running regardless of how much RAM you have in your machine.

How to use this manual
I suggest that you jump right into the tutorials to get acquainted with B² Logic 2.2. Then you can consult the other sections for reference.

Technical Support
Send electronic mail to 71620.3474@compuserve.com. If you can't send computer mail, then call (313) 663-4309 between 9AM and 5PM Eastern time.

Tutorial #1
Build a three input AND function
During this tutorial, you will build a three input AND function out of a three input Nand gate (7410) and an Inverter (7404). A picture of the final circuit is shown below.

Open the B² Logic™ program
This will bring up a clean circuit window. The selection arrow should be the active cursor. Below the tools in the upper left corner of the screen is the current device library's title, LS Library, and the contents of the LS library are given in a scrolling listbox below the title. The box reading 0 ns in the upper right represents the simulation time. It is zero because you have not told B² Logic to start simulating the circuit yet.
As a first step, switch from the LS library to the Standard library. Pull down the Devices menu, and notice that the first item in the list is a sub-menu titled Library. Keep the mouse button down and move to the right past the arrow, and choose the Standard library from the library list.

2. Insert an Input
Click on the 1-bit Input in the components list, then move the cursor into the circuit area. The ghost image of the input port will be following the arrow. Click the mouse button, and you'll have an input port. To deselect the input port, click anywhere else in the circuit area.

3. Add two more Inputs
The input port is still selected (gray). If it isn't, then click on it to select it. Choose Copy from the Edit menu. Then choose Paste from the Edit menu. Place the new 1-bit Input below the first. Choose Paste from the Edit menu again, and place the third 1-bit input below the second.
On the Macintosh, the short-cut for Copy is to hold down the command key while depressing C (Cmd-C).
4. **Insert a three-input Nand gate**
   Choose the 74110/3 3-input Nand from the components list. Place the nand gate to the right of the three input ports. See below for a picture of the circuit after step 4.

5. **Draw the first wire**
   Click on the line drawing tool (the one that looks like \( \backslash \)\) in the upper left hand corner of the circuit window. The cursor will change into a crosshair. Now you can draw the wires.
   Click at the rightmost end of the output pin of the top input port. Release the mouse button and move the mouse, and the wire will follow the cursor. Move to the location where you want the first segment of the wire to end, and click once there. Continue drawing segments until you reach the left end of the top input pin of the Nand gate, then double click. The first wire should now be complete. If there is still a wire following the cursor around, then hit the delete key to eliminate it.

6. **Place and connect the Inverter**
   Select the 7404/6 Inverter from the components list, and place it to the right of the 3-input nand. Draw a wire connecting the output pin of the 3-input nand gate to the input of the inverter, using the method you learned in step 5.

7. **Place and connect an output probe**
   Select the Output Probe from the components list. The circuit will now look like this.

8. **Rename the inputs and outputs**
   The circuit is now functionally complete. Double click on the top input port where it says In and a dialog box will appear asking for the name and value. Enter A for the name. Then double click on the second input port where it says In and type B. Repeat the procedure to change the name of the third input to C, and to rename the output from Out to Q.

9. **Test the Circuit**
   If the cursor is not an arrow, then choose the Selection Tool by selecting the arrow from the toolbox. Choose Step from the Simulation Menu. The simulation time will increase to 20ns, and the output's value will change to 0. Now set the value of the inputs to one by clicking on the up arrow of each input. Using the probe tool, the rightmost tool in the toolbox, you can probe the value and strength of any wire in the circuit. Simply position the left end of the probe tool on the wire, and depress the mouse button.
Choose Step from the Simulation menu again. The simulation time will increase to 40ns, and the output value will change to 1. A picture of the circuit after this step follows.

11. Save the Circuit
Now choose Save from the File menu. Since the circuit does not have a name yet, the computer will prompt you to name the circuit. Name it, then you can quit and take a break. Congratulations! You have built a 3-input And function, similar to the 74LS11.

---

**Tutorial #2**

**Build a hierarchical circuit**

This tutorial will help you learn how to use busses (grouped wires), user-defined subcircuits, the trace window, and command files. The final circuit will be capable of calculating X+Y+Z, where X, Y, and Z can range from 0 to FF in hexadecimal (255 in decimal). The final circuit is shown below.

The component titled 8-bit Adder, which is used twice in the circuit above, is a User-Defined Circuit. The first part of this tutorial involves the design of the 8-bit Adder component. The second part will involve the design of the 3-way Adder shown in the figure above. If you don’t want to spend the time on the first part of the tutorial, the result of the first part can be found in the file 8-bit Adder on the B2 Logic disk, and you can go on to Part II.

The file is named Adder3x8.ckt on the PC.

**Part I: Design of the 8-bit Adder.**

You should already be familiar with drawing wires, placing components, and naming inputs and outputs. If you aren’t, then you should go through tutorial number 1. A picture of the 8-bit Adder follows.